Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59018 - [openconnect] Should use vpnc-script from openconnect

Attached to Project: Arch Linux
Opened by Trygve Aaberge (trygveaa) - Friday, 15 June 2018, 10:40 GMT
Last edited by Levente Polyak (anthraxx) - Wednesday, 21 August 2019, 21:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
openconnect currently uses vpnc-script from the vpnc package. This script hasn't been updated for four years and has several bugs which makes openconnect unusable. Most importantly, it places multiple domains in the domain entry of resolv.conf, which isn't valid syntax and breaks dns resolving (reported in  FS#53938 ). It doesn't support systemd-resolved either, which also breaks dns-resolving if you use that.

openconnect has their own version of the script which they suggest to use instead. This script resolves the two issues mentioned above, and adds support for IPv6 among other things. It would be great if the openconnect package could use this script instead.

It is mentioned on http://www.infradead.org/openconnect/vpnc-script.html and is available from http://git.infradead.org/users/dwmw2/vpnc-scripts.git.

Additional info:
* package version(s): openconnect 1:7.08-1, vpnc 0.5.3.svn550-2
This task depends upon

Closed by  Levente Polyak (anthraxx)
Wednesday, 21 August 2019, 21:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  1:0.5.3.r462.r78-1
Comment by Levente Polyak (anthraxx) - Tuesday, 12 February 2019, 01:21 GMT
Please try again with vpnc 1:0.5.3.r452.r67-1
Comment by Trygve Aaberge (trygveaa) - Tuesday, 12 February 2019, 18:52 GMT
Thanks!

Though, unfortunately, the new vpnc-script doesn't work on Arch systems not using systemd-resolved because it incorrectly assumes systemd-resolved is used when resolve is specified in /etc/nsswitch.conf. I noticed this a while ago, and thought I posted a comment here, but I must have forgotten to do that. Sorry for that.

When I noticed it, I posted a patch with a fix to the openconnect mailing list, but I never received any response for it. I see that they use GitLab now, so I've opened an issue there: https://gitlab.com/openconnect/openconnect/issues/22

If they don't respond there shortly, it would be nice if you could apply the patch to the Arch package. Otherwise, vpnc-script won't work both for systems with and without systemd-resolved. The patch is available here: http://lists.infradead.org/pipermail/openconnect-devel/2018-August/005009.html

Loading...