Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59009 - [fontconfig] metric

Attached to Project: Arch Linux
Opened by Archie The Penguin (opus10) - Thursday, 14 June 2018, 11:13 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 18 June 2018, 14:08 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

reorder <family> list for sans/serif so metric compatible fonts are preferred instead of dejavu
- add liberation sans/serif/mono
- put metric fonts on the top of the list
- put dejavu and non metric fonts on the bottom

Additional info:

* package version(s)
https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/fontconfig&id=1218c4645aa42f766ef7822b6bb772361c9da4b8

* config and/or log files etc.
/etc/fonts/conf.avail/60-latin.conf

https://wiki.archlinux.org/index.php/Metric-compatible_fonts
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 18 June 2018, 14:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Config issue, as far as I can tell (there's no such thing as "metric" fonts)
Comment by loqs (loqs) - Thursday, 14 June 2018, 16:47 GMT
/etc/fonts/conf.avail/60-latin.conf is supplied by upstream what has been upstream's response to your suggestion?
Is the working assumption that a font specifying sans actually means Times , serif means Helvetica and mono means Courier?

Loading...