Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59004 - [bind] build fails if jsoncpp is installed

Attached to Project: Arch Linux
Opened by Pascal E. (hardfalcon) - Thursday, 14 June 2018, 00:13 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 14 June 2018, 02:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Building bind 9.13.0-2 fails if jsoncpp is installed on the build system. The reason seems to be that in this case, the build process selects jsoncpp's header files from /usr/include/json/ over the of the json-c header files from /usr/include/json-c/.

In my case, I used jsoncpp 1.8.4-2 and json-c 0.13.1-1, but the exact versions of these libaries probably arent't important for this bug report.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 14 June 2018, 02:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Packages in the repos are meant to be built in a clean chroot

Loading...