Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58997 - [xorg-xkbcomp] Version 1.4.2-1 crashes computer when waking from suspend

Attached to Project: Arch Linux
Opened by Aleksanteri Paakkinen (wixtb0t) - Wednesday, 13 June 2018, 09:54 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 17 June 2018, 19:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
xorg-xkbcomp 1.4.2-1 makes my laptop reboot (or crash?) when trying to wake from suspend. Downgrading to 1.4.1-2 fixes this issue.

The journalctl logs look normal up until the point where I try to wake up the computer at which point they just end. It looks kind of as if the computer had run out of battery during sleep.

Commits in the upstream seem to change the way xkbcomp reacts to illegal keycodes so I'm not sure if the bug is actually in xkbcomp or some other package. The relevant commits from xorg-xkbcomp:

-- Actual changes
https://cgit.freedesktop.org/xorg/app/xkbcomp/commit/?id=5bc2849273a224a2df593b7e8df31f0bde666482

-- A version bumb
https://cgit.freedesktop.org/xorg/app/xkbcomp/commit/?id=2abe23d23d3755335c10ff573e4e1f93b682e9d9


Steps to reproduce:
Closing lid or using systemctl suspend correctly puts the laptop to sleep. But upon opening the lid or pressing any buttons on the keyboard the laptop reboots instead of waking up.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 17 June 2018, 19:05 GMT
Reason for closing:  Works for me
Comment by Andreas Radke (AndyRTR) - Wednesday, 13 June 2018, 15:33 GMT
Please report this upstream.
Comment by Aleksanteri Paakkinen (wixtb0t) - Sunday, 17 June 2018, 12:35 GMT
After reinstalling the current version of the library the problem has disappeared. So I will request closure for the bug.

Loading...