Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#5899 - post install messages should appear last

Attached to Project: Pacman
Opened by héctor (hacosta) - Sunday, 26 November 2006, 18:27 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 08 December 2006, 23:06 GMT
Task Type Feature Request
Category
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

i think pacman should output post install messages after all packages are done updating for example
pacman -Syu
upgrading nvidia... done.
upgrading X... done.
upgrading Y... done.
upgrading Z... done.
-------------------------------
By using this package you accept the NVIDIA license,
blah blah blah notice that i dont show this message until all packages are done. blah blah blah

This task depends upon

Closed by  Aaron Griffin (phrakture)
Friday, 26 January 2007, 16:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Install messages will remain in the order they are in, BUT are logged to pacman.log (in CVS)
Comment by David Baylis (castro) - Sunday, 26 November 2006, 19:25 GMT
I did at one time suggest that the messages were written to a file for reading after updating.

If you have a large number of Packages to update and you leave it unattended,
it is possible to miss the messages because they have gone off the screen.

A message at the end of updating suggesting that you read the file would be good.
Comment by Roman Kyrylych (Romashka) - Tuesday, 28 November 2006, 03:27 GMT
this was already suggested on pacman-dev MLs and on this bugtracker, don't remember bug reports now.
Comment by héctor (hacosta) - Tuesday, 28 November 2006, 03:35 GMT
sorry i looked for it but couldnt find it. if its here somewher feel free to close this
Comment by Aaron Griffin (phrakture) - Friday, 08 December 2006, 23:06 GMT
pacman3 does log to the pacman.log file. Is this sufficient, or would you like a "please see this file" message?

Personally, I think it's important to show upgrade messages _as they happen_ and not after, as sometimes these messages include application output (i.e. scrollkeeper)
Comment by Roman Kyrylych (Romashka) - Friday, 08 December 2006, 23:08 GMT
> pacman3 does log to the pacman.log file. Is this sufficient
IMO yes.

> Personally, I think it's important to show upgrade messages _as they happen_ and not after
Agree. There's no need to show them after because they will be logged to pacman.log anyway.

Comment by Roman Kyrylych (Romashka) - Wednesday, 24 January 2007, 11:02 GMT Comment by Aaron Griffin (phrakture) - Friday, 26 January 2007, 16:18 GMT
Soo... consensus? Is logging to pacman.log sufficient for the original feature request?
Comment by Roman Kyrylych (Romashka) - Friday, 26 January 2007, 16:36 GMT
I think yes.
Users just must learn this feature (but this will be the case with pacman2->pacman3 switch anyway).

Loading...