Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58983 - [python2] libnsl dependency should be optional

Attached to Project: Arch Linux
Opened by Leonid Isaev (lisaev) - Tuesday, 12 June 2018, 16:40 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 15 June 2018, 04:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Currently, the package extra/python2 depends on libnsl (to support the NIS module [1]), but in fact the only binary in the entire package that links to libnsl.so.2 is /usr/lib/python2.7/lib-dynload/nis.so. Clearly, only a small fraction of systems having the python stack would ever interface with a NIS domain. Hence, is it possible to make libnsl an optdep? For example, "libnsl: for the NIS module".

Thanks!

[1] https://docs.python.org/2/library/nis.html
This task depends upon

Comment by Eli Schwartz (eschwartz) - Thursday, 14 June 2018, 00:06 GMT
I'm not sure what the purpose of this change would be. It's a 200kb package with exactly one dependency and that is required by pam anyway. What do you save by breaking this admittedly uncommon module by default? :p

Aside: this applies equally to python 3...

Loading...