Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58975 - [qtcreator] qt-creator fails to start with file-errors

Attached to Project: Arch Linux
Opened by Tom (tomz) - Monday, 11 June 2018, 22:24 GMT
Last edited by Antonio Rojas (arojas) - Friday, 22 June 2018, 21:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

As a long qtcreator user I have existing settings, projects etc.
Today after upgrading to extra/qtcreator 4.6.2-1 [installed]
I started receiving strange error dialogs on startup. Multiple items and I could not do anything other than quit. Which gave me various more such dialogs.

Example dialog text;
"Cannot overwrite file /home/me/.config/QtProject/qtcreator/devices.xml: Unknown error"

That file exists just fine and after git cloning and compiling the same version of qtcreator manually this issue goes away. So its likely a build error.
Maybe you forgot to rebuild creator after Qt updated?
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 22 June 2018, 21:08 GMT
Reason for closing:  Works for me
Additional comments about closing:  Ask for reopen if you can provide more info, otherwise there's nothing we can do
Comment by Antonio Rojas (arojas) - Monday, 18 June 2018, 14:25 GMT
Not much we can do here without more details or a way to reproduce. What's the full terminal output? What filesystem is your home directory in?
Comment by Alex M Gutowski (WurdahMekanik) - Friday, 22 June 2018, 20:47 GMT
I had this problem as well, but it turned out to be some sort of issue with project file incompatibility. Not at all sure how this became a problem. Recompiling from git produced a different error when compiling any version, including the version I had used previously.

I was able to fix these issues by deleting the ~/.config/QtProject directory and reinstalling qtcreator. It is likely you will need to reconfigure kits and project configurations after doing so. I consider this a sufficient fix, but others may not deem it so.



After my fix, I can not find a way to reproduce the issue. Only one partition is in use on my system, utilizing the ext4 filesystem.

Loading...