Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58974 - [borg] msgpack-python incompatible

Attached to Project: Community Packages
Opened by Stephan Eisvogel (bsdice) - Monday, 11 June 2018, 19:15 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 12 June 2018, 17:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:

Package broken as of today's 1.1.6-1 update.

# borg
Traceback (most recent call last):
File "/usr/bin/borg", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3095, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3079, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 570, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 888, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 774, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'msgpack-python!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6' distribution was not found and is required by borgbackup

Additional info:
# pacman -Q |grep msgpack
python-msgpack 0.5.6-1
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 12 June 2018, 17:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  borg 1.1.6-2
Comment by Vijay Marupudi (vijaygopalmarupudi) - Monday, 11 June 2018, 19:49 GMT
Can confirm, same exact error.
Comment by Ben Oliver (benoliver999) - Monday, 11 June 2018, 21:35 GMT
Seconded
Comment by Radon Rosborough (raxod502) - Monday, 11 June 2018, 22:07 GMT
Workaround:

$ pip install msgpack-python

See also: https://github.com/borgbackup/borg/issues/3889
Comment by Daniel Hahler (blueyed) - Monday, 11 June 2018, 22:33 GMT
A workaround is to comment "msgpack-python!=0.5.0,!=0.5.1,!=0.5.2,!=0.5.3,!=0.5.4,!=0.5.5,<=0.5.6,>=0.4.6" in /usr/lib/python3.6/site-packages/borgbackup-1.1.6-py3.6.egg-info/requires.txt (by adding "# " in front).

I am not sure where those specific versions are coming from.
borg's PKGBUILD does the following only:
sed -i "s/msgpack-python>=.*/msgpack',/g" setup.py
Comment by Eli Schwartz (eschwartz) - Monday, 11 June 2018, 22:51 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Critical → High)
  • Task assigned to Lukas Fleischer (lfleischer)
Comment by Eli Schwartz (eschwartz) - Monday, 11 June 2018, 22:53 GMT
This keeps happening because upstream plays monkey games with the pinned versions and insists on using deprecated names, then trying to overload that with ancient versions only needed to keep python34 compat.

So our fix no longer applied once the format of the setup.py changed again...
Comment by Eli Schwartz (eschwartz) - Tuesday, 12 June 2018, 02:49 GMT
Trying to get this fixed upstream in a consistent manner: https://github.com/borgbackup/borg/pull/3891

Loading...