Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58968 - [docker-compose] dependency on python-idna

Attached to Project: Community Packages
Opened by Martin Zajíc (zajca) - Monday, 11 June 2018, 12:03 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 11 June 2018, 12:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
docker-compose package has unlisted dependency on package python-idna.
With update to 'extra/python-idna 2.7-2' 'docker-compose 1.21.2' won't work and will throw error:

'pkg_resources.DistributionNotFound: The 'idna<2.7,>=2.5' distribution was not found and is required by requests'

'python-idna' should be add as dependency with constraint '<2.7,>=2.5'
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 11 June 2018, 12:23 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 11 June 2018, 12:23 GMT
The error very clearly shows that the issue is with requests, not docker-compose. python-requests was updated to fix this less than an hour after python-idna was updated; that was a number of hours ago now. You're out of date.

Loading...