Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58896 - [icewm] segfault on startup

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Wednesday, 06 June 2018, 19:47 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 09 June 2018, 06:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Starting icewm yields:

Core was generated by `icewm'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x000055e3d8d2926e in YPixmap::replicate(bool, bool) ()
(gdb) bt
#0 0x000055e3d8d2926e in YPixmap::replicate(bool, bool) ()
#1 0x000055e3d8cd1e02 in _ZL11initPixmapsv ()
#2 0x000055e3d8cd675e in YWMApp::YWMApp(int*, char***, char const*) ()
#3 0x000055e3d8caf044 in main ()

Root cause is a null:ref for ceratin pixmaps in initPixmaps.

See also: https://bbs.archlinux.org/viewtopic.php?pid=1790157#p1790157 and
https://git.archlinux32.org/archlinux32/packages/src/commit/92e141a141c520f54285c026fb2a48f81115290d/extra/icewm/icewm-1.3.8-pixmap-null-ref.patch

Additional info:
* package version(s): icewm-1.3.8-5
* config and/or log files etc.


Steps to reproduce:

makepkg -s
startx (with icewm in .xinitrc)
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 09 June 2018, 06:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  icewm 1.4.2
Comment by Jason Begley (jayray) - Thursday, 07 June 2018, 00:49 GMT
Can confirm, the same exists on my build. Downgrade to icewm-1.3.8-4 make is go away.

Process 15467 (icewm) of user 1002 dumped core.

Stack trace of thread 15467:
#0 0x00005646e947626e n/a (icewm)
#1 0x00005646e941ee02 n/a (icewm)
#2 0x00005646e942375e n/a (icewm)
#3 0x00005646e93fc044 n/a (icewm)
#4 0x00007f61bd6ba06b __libc_start_main (libc.so.6)
#5 0x00005646e93fd66a n/a (icewm)

Loading...