Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58893 - laptop keyboard & touchpad doesn't work

Attached to Project: Arch Linux
Opened by step-2 (step-2) - Wednesday, 06 June 2018, 16:45 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 09 June 2018, 16:45 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

i get no keyboard and touchpad since kernel 4.17

Additional info:
* package version(s) kernel 4.17
* config and/or log files etc.


Steps to reproduce:

install 4.17 and reboot .

the hardware is Asus Zenbook ux303ub ,

any logs needed i will supply it .
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 09 June 2018, 16:45 GMT
Reason for closing:  None
Additional comments about closing:  Refuses to look up anything or post actual info
Comment by loqs (loqs) - Wednesday, 06 June 2018, 22:47 GMT
Does the keyboard would outside of X?
Have you compared the dmesg outputs and lsmod outputs for changes?
Comment by step-2 (step-2) - Thursday, 07 June 2018, 02:08 GMT
i see this in dmesg repeated a few times :

[ 52.633484] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
[ 52.633488] pcieport 0000:00:1c.5: device [8086:9d15] error status/mask=00000001/00002000
[ 52.633492] pcieport 0000:00:1c.5: [ 0] Receiver Error (First)

and no the keyboard and touchpad and pattery reporting all not working in wayland and xorg
Comment by step-2 (step-2) - Thursday, 07 June 2018, 03:26 GMT
here is lsmod from the two kernels .
Comment by loqs (loqs) - Thursday, 07 June 2018, 10:21 GMT
The following modules are not present in the 4.17 lsmod output no new modules were present
ac
acpi_als
acpi_thermal_rel
asus_nb_wmi
asus_wireless
asus_wmi
atkbd
battery
i8042
industrialio
input_leds
int3400_thermal
int3403_thermal
joydev
kfifo_buf
libps2
mxm_wmi
psmouse
rng_core
serio
serio_raw
sparse_keymap
tpm
tpm_crb
tpm_tis
tpm_tis_core
wmi
Comment by step-2 (step-2) - Thursday, 07 June 2018, 16:05 GMT
how do i load them ?
Comment by step-2 (step-2) - Friday, 08 June 2018, 03:04 GMT
ok loading the modules through /etc/module-load.d didn't solve the issue .
Comment by step-2 (step-2) - Friday, 08 June 2018, 06:07 GMT
ok loading the modules through /etc/module-load.d didn't solve the issue .
Comment by Doug Newgard (Scimmia) - Saturday, 09 June 2018, 05:28 GMT
Do they actually get loaded when you do that?
Comment by step-2 (step-2) - Saturday, 09 June 2018, 16:25 GMT
i don't know , but modprobe the module also don't work
Comment by Doug Newgard (Scimmia) - Saturday, 09 June 2018, 16:33 GMT
"I don't know" doesn't help. Find out.

"also don't work" also doesn't help. Give is actual info, errors, etc.
Comment by step-2 (step-2) - Saturday, 09 June 2018, 16:42 GMT
what info you need , plus you didn't give actual solution ,

also am not a kernel hacker , am an average user ,

modprobing the modules doesn't solve the issue ,

what info you need and i will provide it .

Loading...