Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58885 - The package "gdk-pixbuf2" has an undocumented dependency, leading to confusion.

Attached to Project: Community Packages
Opened by Wolf0 (Wolf0) - Tuesday, 05 June 2018, 18:51 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 05 June 2018, 19:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I have only tested x86_64, but I would assume it is present in the x86 version as well - the "gdk-pixbuf2" package requires at least the extra/gvfs package, which is not listed as a dependency.

* package version(s)

gdk-pixbuf2 was version 2.36.11.1, the upgrade was to 2.36.12.1.

* config and/or log files etc.

Upon install:

pacman -S gdk-pixbuf2
resolving dependencies...
looking for conflicting packages...

Packages (1) gdk-pixbuf2-2.36.12-1

Total Download Size: 0.63 MiB
Total Installed Size: 3.90 MiB
Net Upgrade Size: 0.12 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
gdk-pixbuf2-2.36.12-1-x86_64 648.1 KiB 149K/s 00:04 [################################] 100%
(1/1) checking keys in keyring [################################] 100%
(1/1) checking package integrity [################################] 100%
(1/1) loading package files [################################] 100%
(1/1) checking for file conflicts [################################] 100%
(1/1) checking available disk space [################################] 100%
:: Processing package changes...
(1/1) upgrading gdk-pixbuf2 [################################] 100%
:: Running post-transaction hooks...
(1/2) Probing GDK-Pixbuf loader modules...
'g_io_module_load': /usr/lib/gio/modules/libgiolibproxy.so: undefined symbol: g_io_module_load
Failed to load module: /usr/lib/gio/modules/libgiolibproxy.so
'g_io_module_load': /usr/lib/gio/modules/libgiognutls.so: undefined symbol: g_io_module_load
Failed to load module: /usr/lib/gio/modules/libgiognutls.so
'g_io_module_load': /usr/lib/gio/modules/libgiognomeproxy.so: undefined symbol: g_io_module_load
Failed to load module: /usr/lib/gio/modules/libgiognomeproxy.so
(2/2) Arming ConditionNeedsUpdate...

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 05 June 2018, 19:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is a partial update problem. Unsupported

Loading...