Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58878 - [python-requests] python-urllib3 1.23 not supported

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Tuesday, 05 June 2018, 14:52 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 07 June 2018, 11:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

$ python -c 'import requests'
/usr/lib/python3.6/site-packages/requests/__init__.py:80: RequestsDependencyWarning: urllib3 (1.23) or chardet (3.0.4) doesn't match a supported version!
RequestsDependencyWarning)

It's a warning, so requests is still working. Just annoying.

Additional info:
python-urllib3 1.23-1
python-requests 2.18.4-1

Steps to reproduce:
As described above
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 07 June 2018, 11:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-requests 2.18.4-3
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 05 June 2018, 14:54 GMT Comment by Doug Newgard (Scimmia) - Tuesday, 05 June 2018, 15:10 GMT
It's in requires.txt, so it's more than an annoyance.  FS#58880 .
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 05 June 2018, 16:34 GMT
  • Field changed: Percent Complete (100% → 0%)
The story has not reached the end: https://github.com/requests/requests/pull/4671
Comment by Rob (ethanol) - Wednesday, 06 June 2018, 09:21 GMT
Is this what causes the following output constantly on my machine?

> /usr/lib/python3.6/site-packages/requests/__init__.py:80: RequestsDependencyWarning: urllib3 (1.23) or chardet (3.0.4) doesn't match a supported version!
RequestsDependencyWarning)

I already tried reinstalling the various python / python2 system packages, but with little success.
Comment by lilydjwg (lilydjwg) - Wednesday, 06 June 2018, 09:22 GMT
Rob: yes.
Comment by Felix Yan (felixonmars) - Wednesday, 06 June 2018, 17:57 GMT
Should have been fixed in 2.18.4-3.
Comment by Chih-Hsuan Yen (yan12125) - Thursday, 07 June 2018, 09:27 GMT
Felix Yan: I can confirm the warning has gone in 2.18.4-3. Thank you very much for the prompt fix!

Loading...