Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58847 - [thunar] MIME Type for executable not identified correctly with gcc -pie

Attached to Project: Arch Linux
Opened by marcus philpott (pha-qu2) - Sunday, 03 June 2018, 00:37 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 30 November 2018, 05:13 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is an upstream bug already reported here https://bugzilla.xfce.org/show_bug.cgi?id=13750 (it applies to pcmanfm too), compiled executable files in user space are identified as shared object files. Since gcc defaulted to 'silently' using the -pie option thunar doesn't identify the application MIME type correctly. Attempting to launch a -pie executable from thunar activates the context application chooser menu to display.


Additional info:
Thunar 1.6.15
gcc (GCC) 8.1.0 (8.1.0-1 in Arch repo?)

Steps to reproduce:

Compile a simple test program.

gcc helloworld.c -o helloworld
file helloworld
helloworld: ELF 64-bit LSB pie executable x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, BuildID[sha1]=4343e7cf7432c88a3974d88e07e7e5f5cf5f92a8, not stripped

executable file will not launch from thunar

Recompile with -pie option disabled

gcc -no-pie helloworld.c -o helloworld
file helloworld
helloworld: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, BuildID[sha1]=e6f51544e86c8454bb1a65e4fa809d13484d9114, not stripped

executable file will launch from thunar

This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 30 November 2018, 05:13 GMT
Reason for closing:  Upstream
Additional comments about closing:  Nothing actionable for us to do here, and upstream is notified.
Comment by loqs (loqs) - Sunday, 03 June 2018, 01:49 GMT

Loading...