Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58830 - [xorg-xdm] Built without systemd support

Attached to Project: Arch Linux
Opened by (IrvineHimself) (IrvineHimself) - Friday, 01 June 2018, 15:08 GMT
Last edited by Jan de Groot (JGC) - Monday, 18 June 2018, 14:40 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 26
Private No

Details

Description:
xorg-xdm crashes after a few minutes due to configure.ac not reflecting recent changes to systemd

Additional info:
* xorg-xdm 1.1.11-7
* https://bbs.archlinux.org/viewtopic.php?id=237578
* https://bbs.archlinux.org/viewtopic.php?id=237592


The patch proposed by @loqs appears to fix the problem :
https://bbs.archlinux.org/viewtopic.php?pid=1788945#p1788945
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 18 June 2018, 14:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  xorg-xdm-1.1.11+50+gb685338-1
Comment by loqs (loqs) - Friday, 01 June 2018, 15:38 GMT
From https://github.com/systemd/systemd/blob/master/NEWS CHANGES WITH 230:
* The compatibility libraries libsystemd-daemon.so,
libsystemd-journal.so, libsystemd-id128.so, and libsystemd-login.so
which have been deprecated since systemd-209 have been removed along
with the corresponding pkg-config files. All symbols provided by
those libraries are provided by libsystemd.so.
configure.ac from xorg-xdm is still looking for libsystemd-daemon when it fails it disables systemd support.
Without systemd support xorg-xdm does not use sd_notify however the service file specified type=notify.
This causes the service to be killed as having failed in startup after the startup timeout has expired with no sd_notify received by systemd.
Comment by Allen Li (darkfeline) - Sunday, 03 June 2018, 04:16 GMT
Can confirm, I got bit by this. It's very annoying because it causes a crash to tty after a few seconds and would be very hard to figure out for most users.
Comment by Andrea Chiavazza (ndr76) - Sunday, 03 June 2018, 13:33 GMT
I can confirm the bug happening with xorg-xdm-1.1.11-7. Downgrading to xorg-xdm-1.1.11-6 fixes the problem.
Comment by Ladislav Laska (Krakonos) - Monday, 04 June 2018, 11:11 GMT
Can confirm the issue with -7, downgrade to -6 works well. Took me a while to figure out what's going on.
Comment by Dmytro Bagrii (dimich) - Monday, 04 June 2018, 11:21 GMT
Can confirm too.
Comment by Johannes Dewender (JonnyJD) - Monday, 04 June 2018, 17:00 GMT
The bug title is still " PLEASE ENTER SUMMARY ". This should probably be changed to get "better" attention.

I can confirm the problem and that the patch is working.

With the official package 1.1.11-7 (I updated with pacman -Syu today):
When starting xdm it fails after a bit more than a minute (but showing the actual login screen in that time).
This is in "systemctl status":
Starting X-Window Display Manager...
Start operation timed out. Terminating.
Failed with result 'timeout'
Failed to start X-Window Display Manager

When rebuilding the package without any changes with extra-x86_64-build
I get the same result (xdm closes after a bit more than a minute)

When building the package with the attached patch
Everything is working fine now (= running for 10 minutes without xdm stopping)
Comment by loqs (loqs) - Monday, 04 June 2018, 20:38 GMT
@JonnyJD only a bug wrangler or developer can change the task details including the title the details are locked from others including the bug reporter.
Comment by (IrvineHimself) (IrvineHimself) - Tuesday, 05 June 2018, 01:19 GMT
@JonnyJD, sorry about that. It's the first time I reported a bug and I didn't realise it was the title bar, (and editable,) I thought it was an instruction for the box below.
Comment by Johannes Dewender (JonnyJD) - Tuesday, 05 June 2018, 11:46 GMT
This should also be reported upstream, right?
https://bugs.freedesktop.org/
The code changed by the patch is not in Arch packaging, but the upstream configure.ac:
https://cgit.freedesktop.org/xorg/app/xdm/
Comment by loqs (loqs) - Thursday, 07 June 2018, 13:53 GMT
@JonnyJD correct although the patch itself would need work before it could be included upstream as it does not cover the case of systemd version less than 209.
It also does not change installing the service file even if systemd daemon detection failed or the fallback tests for detecting systemd.
Comment by loqs (loqs) - Sunday, 10 June 2018, 12:28 GMT

Loading...