Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58819 - [python-netcdf4] Depends on netcdf-openmpi

Attached to Project: Community Packages
Opened by Fazlul Shahriar (fhs) - Friday, 01 June 2018, 07:44 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Friday, 01 June 2018, 21:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to update python-netcdf4, I get this:

$ sudo pacman -Sy python-netcdf4
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
resolving dependencies...
looking for conflicting packages...
:: netcdf-openmpi and netcdf are in conflict. Remove netcdf? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: netcdf-openmpi and netcdf are in conflict


I seems this package now depends on netcdf-openmpi when it used to depend
on netcdf:

$ pacman -Qi python-netcdf4
Name : python-netcdf4
Version : 1.3.1-1
Description : Python/NumPy interface to the netCDF C library
Architecture : x86_64
URL : https://unidata.github.io/netcdf4-python
Licenses : MIT
Groups : None
Provides : None
Depends On : python-numpy netcdf
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 2.50 MiB
Packager : Bruno Pagani <archange@archlinux.org>
Build Date : Wed 01 Nov 2017 02:29:38 PM EDT
Install Date : Fri 10 Nov 2017 05:31:46 PM EST
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

$ pacman -Si python-netcdf4
Repository : community
Name : python-netcdf4
Version : 1.4.0-1
Description : Python/NumPy interface to the netCDF C library (openmpi version)
Architecture : x86_64
URL : https://unidata.github.io/netcdf4-python
Licenses : MIT
Groups : None
Provides : None
Depends On : python-numpy python-cftime python-mpi4py netcdf-openmpi
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 454.68 KiB
Installed Size : 1889.00 KiB
Packager : Bruno Pagani <archange@archlinux.org>
Build Date : Wed 23 May 2018 06:03:08 PM EDT
Validated By : MD5 Sum SHA-256 Sum Signature


I don't see any mention of openmpi in the PKGBUILD found at
https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/python-netcdf4
So, I'm assuming this is just a bad build that was uploaded to the
pacman repo. The same issue exists for python2-netcdf4.

I've tested with these two mirrors:
Server = http://mirror.cc.columbia.edu/pub/linux/archlinux/$repo/os/$arch
Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Friday, 01 June 2018, 21:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  python{,2}-netcdf4 1.4.0-2
Comment by Bruno Pagani (ArchangeGabriel) - Friday, 01 June 2018, 17:22 GMT
No, it’s a failure on my side in python-netcdf4-openmpi: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/python-netcdf4-openmpi&id=a66a765fca9dd512c1bbcd91578abb265acc9d1f

I’ll fix it when back at home, sorry for the annoyance.

Loading...