Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58803 - [librsvg] Cairo-dock crashes on start after the update to librsvg 2.42.4

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Thursday, 31 May 2018, 08:19 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 03 June 2018, 04:38 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After librsvg has been updated to 2.42.4, cairo-dock crashes on start up. A bug report at Launchpad exists with all relevant output: https://bugs.launchpad.net/cairo-dock-core/+bug/1770884 I reported the bug upstream (in the forums as advised on the cairo-dock website and later also by mailing to the devs) but it looks like cairo-dock is abandoned.

Steps to reproduce:

Install the latest updates, launch cairo-dock
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 03 June 2018, 04:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  librsvg 2.24.5
Comment by Michael Kogan (Photon) - Friday, 01 June 2018, 09:14 GMT
Further findings:

1. The bug appears on some machines but not on all: I have a Manjaro install where librsvg has been updated to .4 already and the bug doesn't appear.

2. The bug appears only if the plugins package cairo-dock-plug-ins is installed.

3. Rebuilding the core and plugins packages didn't solve the issue.

4. The first commit to librsvg causing this bug is https://github.com/GNOME/librsvg/commit/628180823876d7ff446f5d6cb5f8448b65d287a2 Bisection log: https://pastebin.com/ytM64MBa
Comment by Michael Kogan (Photon) - Friday, 01 June 2018, 12:21 GMT
Reported issue upstream at librsvg: https://gitlab.gnome.org/GNOME/librsvg/issues/276
Comment by loqs (loqs) - Friday, 01 June 2018, 16:02 GMT
There currently does not appear to be a librsvg 2.24.5 release https://gitlab.gnome.org/GNOME/librsvg/commit/b99692db46e2a6c61d37a70165198ad029c4ec69 could be cherry picked until there is.
Comment by Michael Kogan (Photon) - Friday, 01 June 2018, 16:10 GMT
Looks like it takes a bit till the release is ready. In the mean time a workaround: Make sure that your configuration is not as described in https://bugs.launchpad.net/cairo-dock-core/+bug/1770884/comments/2
Comment by Michael Kogan (Photon) - Saturday, 02 June 2018, 08:10 GMT
librsvg 2.42.5 landed in the repos so now there is nothing preventing this from getting closed. :)

Loading...