Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58780 - [libkate] Python2 dependency should be optional

Attached to Project: Arch Linux
Opened by Frsf Nrrg (frsfnrrg) - Tuesday, 29 May 2018, 16:36 GMT
Last edited by freswa (frederik) - Saturday, 26 September 2020, 19:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

* I'm fairly certain that python2 should count as an optional requirement,
since the kdj python package exists solely for use by KateDJ, doesn't expose
any of the C library API (as it internally just runs the program kateenc with
fixed arguments); is used by no other packages; and furthermore wxpython is
also a dependency of kdj.
This task depends upon

Closed by  freswa (frederik)
Saturday, 26 September 2020, 19:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  libkate 0.4.1-7
Comment by Doug Newgard (Scimmia) - Thursday, 31 May 2018, 15:59 GMT
One issue per ticket. In this case, one of your two issues is already fixed (https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/libkate&id=e0891c201c47283c0ebb99cf77d5450effe51f74), so I'm just going to edit that out.
Comment by Alvaro GarcĂ­a (rainbyte) - Saturday, 25 January 2020, 05:44 GMT
Any news about this? On one of my machines this is the last package using python2
Comment by Philipp Wallisch (Wallcom) - Sunday, 26 January 2020, 05:08 GMT
Debian already did that:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=936883
https://salsa.debian.org/multimedia-team/libkate/commit/7b9b99b5a99d1329cc40ef1d9bf5fef6347a664f

Would be really nice, as this is the last python2 dependend package when installing the 'gnome' group.
Comment by loqs (loqs) - Sunday, 13 September 2020, 14:55 GMT

Loading...