Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#5874 - qemu compiled with gcc4 is broken (at least on Arch64)

Attached to Project: Arch Linux
Opened by Pierre Schmitz (Pierre) - Tuesday, 21 November 2006, 15:13 GMT
Last edited by Thomas Bächler (brain0) - Wednesday, 07 February 2007, 18:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since qemu has moved to extra it is patched to be compiled with gcc4. Those patches introduce some stability-problems on Arch32 and broke the Arch64. qemu exists with a segmentation-fault.

The qemu-devs recommend the use of gcc3.4 (see: http://kidsquid.com/cgi-bin/moin.cgi/FrequentlyAskedQuestions#head-9cd72ae5d3bd7b85d2538c0db933236b3c7e9bd9)

I tested the following PKGBUILDs on Arch32 and Arch64 with success: http://www.archlinux.de/~pierre/src/ (gcc3.4.6 and qemu without any patches)

If devs do not want to have two gcc-packages in [extra] moving qemu back into [community] would be a solution.

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 11 February 2007, 23:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  compiled with gcc3 now
Comment by Thomas Bächler (brain0) - Wednesday, 07 February 2007, 18:11 GMT
I added gcc3.3 to extra. assigning to andy.

Loading...