Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58707 - [xdg-utils] fails to open urls in lxde

Attached to Project: Arch Linux
Opened by Ivan Agarkov (kreon) - Wednesday, 23 May 2018, 21:00 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 13 June 2018, 15:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

xdg-open from xdg-utils 1.1.3-1 fails to open urls ( http/https etc ) in lxde.

The problem is located here:

938 open_lxde()
939 {
940
941 # pcmanfm only knows how to handle file:// urls and filepaths, it seems.
942 if pcmanfm --help >/dev/null 2>&1 -a is_file_url_or_path "$1"; then
############

So when I command 'xdg-open https://site.com'; I get 'no such file or directory' from pcmanfm;

I made a little patch to fix that.

Steps to reproduce:
- install lxde
- run xdg-open http://site.com
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 13 June 2018, 15:42 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Wednesday, 23 May 2018, 21:21 GMT Comment by Ivan Agarkov (kreon) - Friday, 25 May 2018, 03:03 GMT Comment by Andreas Radke (AndyRTR) - Tuesday, 12 June 2018, 17:56 GMT
Patch applied to 1.1.3-2 - please test.
Comment by Ivan Agarkov (kreon) - Wednesday, 13 June 2018, 10:38 GMT
Works as expected

Loading...