Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58696 - [binutils] Gold linker does not select proper symbol visibility when used with LLVM gold-plugin

Attached to Project: Arch Linux
Opened by Thomas Schneider (BlackLotus) - Tuesday, 22 May 2018, 17:05 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Friday, 01 June 2018, 10:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
binutils has a problem in the gold linker leads to some problems.
Here is the patch https://sourceware.org/bugzilla/show_bug.cgi?id=22868#c4 it will be backported, but isn't yet. So

Additional info:
* binutils 2.3 was updated in january, bug was fixed in march
* https://aur.archlinux.org/pkgbase/llvm40/ here is a broken PKGBUILD (because of this bug)


Steps to reproduce:
compile llvm40
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Friday, 01 June 2018, 10:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.30-5

Loading...