Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58650 - xorg,vesa,nomodeset: errors about 'IOPL' and 'int vec'

Attached to Project: Arch Linux
Opened by archu0 (archu0) - Friday, 18 May 2018, 09:51 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 18 May 2018, 10:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The xorg is being used with the vesa driver to drive the IvyBridge built-in graphics.
The kernel boots with nomodeset (I can't remove nomodeset, for other reasons).
Kernel version: 4.16.9-1-ARCH

With 1.19.6+13+gd0d1a694f-2, I could run startx as a normal user.
With xorg-server 1.20.0-2, I could not run startx as a normal user. (I am not sure if 1.20.0-1 works or not.)

The error in Xorg.0.log, with xorg-server 1.20.0-2 is:
[ 1960.314] (II) VESA: driver for VESA chipsets: vesa
[ 1960.314] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
. . .
[ 1960.315] (II) Loading sub module "vbe"
[ 1960.315] (II) LoadModule: "vbe"
[ 1960.315] (II) Loading /usr/lib/xorg/modules/libvbe.so
[ 1960.315] (II) Module vbe: vendor="X.Org Foundation"
[ 1960.315] compiled for 1.20.0, module version = 1.1.0
[ 1960.315] ABI class: X.Org Video Driver, version 24.0
[ 1960.315] (II) Loading sub module "int10"
[ 1960.315] (II) LoadModule: "int10"
[ 1960.315] (II) Loading /usr/lib/xorg/modules/libint10.so
[ 1960.315] (II) Module int10: vendor="X.Org Foundation"
[ 1960.315] compiled for 1.20.0, module version = 1.0.0
[ 1960.315] ABI class: X.Org Video Driver, version 24.0
[ 1960.315] (II) VESA(0): initializing int10
[ 1960.315] (EE) VESA(0): Cannot read int vect
[ 1960.315] (II) UnloadModule: "vesa"
[ 1960.315] (II) UnloadSubModule: "int10"
[ 1960.315] (II) Unloading int10
[ 1960.315] (II) UnloadSubModule: "vbe"
[ 1960.315] (II) Unloading vbe
[ 1960.315] (EE) Screen(s) found, but none have a usable configuration.


Additional info:
* package version(s): 1.20.0-2
* config and/or log files etc.


Steps to reproduce:
- Kernel command line:BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=80c0dd19-c937-424e-9809-f8b4e4522fab rw nomodeset vga=0x160 resume=/dev/sda1 intel_iommu=on

- Upgrade xorg-server from 1.19.6+13+gd0d1a694f-2 to 1.20.0-2
- Reboot
- startx as a normal user fails.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 18 May 2018, 10:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:  OP request: caused by  FS#58644 
Comment by archu0 (archu0) - Friday, 18 May 2018, 10:12 GMT
It looks as if  FS#58644  is related to this bug.

With 1.19.6+13+gd0d1a694f-2, the file /usr/bin/Xorg is a script which chooses between /usr/lib/xorg-server/Xorg.wrap and /usr/lib/xorg-server/Xorg.
With 1.20.0-2, the file /usr/bin/Xorg is an ELF binary (without the suid bit set.)

I am not sure what needs to be done here. Do I need to configure my system for a rootless xorg?
Comment by archu0 (archu0) - Friday, 18 May 2018, 10:16 GMT
Please ignore my last question. It seems an updated package is in the works over at  FS#58644 .

Loading...