Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58642 - zpaq option fails in Alpine 3.7 when compiled from source

Attached to Project: Arch Linux
Opened by Alan Nexus (Alan) - Thursday, 17 May 2018, 17:51 GMT
Last edited by Jan de Groot (JGC) - Thursday, 17 May 2018, 19:45 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

lrzip when building from scratch on Alpine Linux 3.7 (current latest release) consistently segmentation faults using "zpaq" option. I've tried many combinations of options including increasing stack size to unlimited (ulimit) without success.

Additional info:
* package version(s)
It is not a package rather being built from source.
* config and/or log files etc.


Steps to reproduce:
To build on Alpine I follow instructions on (https://github.com/ckolivas/lrzip):
./autogen.sh
./configure
make -j `nproc` # maxes out all cores

I use: lrzip -z <filename.tar>
Then I get Segmentation Fault regardless of any other option I use on Alpine 3.7.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 17 May 2018, 19:45 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 17 May 2018, 19:45 GMT
This is not Alpine linux bugtracker and you're reporting a crashing git snapshot of 3rd party software.

Loading...