Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#5861 - function isalpha() renders different result for the subshell change directory function in mc

Attached to Project: Arch Linux
Opened by aidenn (idn) - Sunday, 19 November 2006, 15:09 GMT
Last edited by Aaron Griffin (phrakture) - Tuesday, 06 November 2007, 17:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity High
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

as written in blfs wiki:

There seems to be a breakage on the newer glibc (I am using 2.5 from CLFS development) and some of the locales. Specifically, function isalpha() renders different result for the subshell change directory function in the Midnight Commander. MC does change directory in the panel but not in the subshell and writes: "Warning: Cannot change to directory ...".

it happens in Arch's mc under bash as well. the fix proposed by lfs wiki works as intended:

sed -i "s|isalpha|\!isdigit|" src/subshell.c

paste it before make in PKGBUILD, works like a charm.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Tuesday, 06 November 2007, 17:58 GMT
Reason for closing:  Implemented
Additional comments about closing:  Merged upstream
Comment by aidenn (idn) - Sunday, 19 November 2006, 15:20 GMT
huh, while it did fix entering directories containing "_", it broke those with "!" (entering, for example, "!tmp" hangs mc completely). it would seem that this problem needs way more fixing. ;)
Comment by aidenn (idn) - Tuesday, 21 November 2006, 17:35 GMT
http://bugs.gentoo.org/show_bug.cgi?id=153925

last patch works flawlessly (attached).
Comment by Nagy Gabor (combo) - Tuesday, 03 April 2007, 11:19 GMT
I think in 0.8 this bug and #5546 should have been fixed:-( Is there any developer assigned to mc?
Comment by Michael Dominic K. (mdk) - Friday, 31 August 2007, 15:51 GMT
Anybody looking in to this per chance? It's a bit annoying.
Comment by Michael Dominic K. (mdk) - Monday, 17 September 2007, 11:47 GMT
I tested the patch proposed, and it fixes the problem.
Comment by Nagy Gabor (combo) - Monday, 17 September 2007, 18:00 GMT
Probably the devels want to celebrate the 1st birthday of this bug :-(
Comment by Aaron Griffin (phrakture) - Monday, 17 September 2007, 18:34 GMT
Sorry all. There seem to be a lot of mc issues in here, and I need to get to all of them at some point. Again, I apologize
Comment by Simo Leone (neotuli) - Tuesday, 06 November 2007, 11:51 GMT
this patch appears to have been merged upstream.

Loading...