Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58583 - [virtualbox-guest-modules-arch] [virtualbox] shared folder write causes loop and corruption

Attached to Project: Community Packages
Opened by xnor (xnor) - Sunday, 13 May 2018, 21:55 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 17 April 2019, 12:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Christian Hesse (eworm)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since virtualbox-guest-modules-arch 5.2.8-11 a pwritev to a file in a shared folder is broken:

It causes a loop on the host, which
a) writes to the same offset,
b) corrupts the data.

Host is a Windows 10. Host version of VirtualBox makes no difference (5.2.8, 5.2.10, 5.2.12).

I first reported this upstream, but after looking at the changes in packaging after 5.8.2-11 I'm not sure anymore that this is an upstream bug.

strace and example program to reproduce the problem are available in the upstream ticket:
https://www.virtualbox.org/ticket/17716#comment:15

This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 17 April 2019, 12:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing due to request saying it's fixed. Re-open if it's not.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 06 June 2018, 22:24 GMT
Seems to be a problem with the new vboxsf module. I've just asked its author about it: https://bugzilla.redhat.com/show_bug.cgi?id=1481630#c80
Comment by xnor (xnor) - Saturday, 11 August 2018, 21:41 GMT
Three months have passed and this still isn't fixed, right?
Comment by Evangelos Foutras (foutrelis) - Saturday, 11 August 2018, 22:25 GMT
Two months since it was mentioned here: https://bugzilla.redhat.com/show_bug.cgi?id=1481630#c80

There were a couple of commits made 4 days ago to the vboxsf repo we pull from, so I added a GitHub issue there: https://github.com/jwrdegoede/vboxsf/issues/2

Not much to do other than wait for the person maintaining it to figure out what's wrong and fix it.
Comment by xnor (xnor) - Thursday, 18 October 2018, 18:46 GMT
Any updates with 5.2.10?
Comment by xnor (xnor) - Wednesday, 07 November 2018, 19:05 GMT
@foutrelis Could you please ping the guy at redhat again, see if he's still alive?

Loading...