Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58571 - [rsync] restart when glibc is upgraded?

Attached to Project: Arch Linux
Opened by lilydjwg (lilydjwg) - Sunday, 13 May 2018, 05:32 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 14 October 2021, 21:51 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jelle van der Waa (jelly)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Every time glibc upgrades, my dcron and rsync services segfaults after forking, and in one day or two I'll notice that something has gone wrong.

I've fixed the dcron one by adding a hook running "/usr/bin/systemctl try-restart dcron". Would you do this for the rsyncd service too?

I'm manually adding a hook on the server but it'll be nicer to include this in the package.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 14 October 2021, 21:51 GMT
Reason for closing:  Works for me
Additional comments about closing:  2021-07-18: A task closure has been requested. Reason for request: Not confirmed. There are no such problems with the latest version.

Loading...