Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58518 - freetype2 2.9.1 no longer provides /usr/bin/freetype-config binary

Attached to Project: Arch Linux
Opened by Tomas K. (Georgo10) - Wednesday, 09 May 2018, 10:12 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 09 May 2018, 10:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

extra/freetype2 prior to version 2.9.1 provided /usr/bin/freetype-config binary, which was used by some other packages (especially in AUR) for compilation.
Since 2.9.1, freetype2 project made this optional and it's not build by default and it's required to add configuration directive `--enable-freetype-config'
Change is described here: http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=b0a93839b52818abbfe9b4c8755b4aa0f5232063

Is possible to add this directive to package, or create new package with it? (Or is best solution to create fork in aur?)

Steps to reproduce:
For example, build of php56 had correct dependencies, but since freetype2 is 2.9.1, it's not able to finish ./configure phase.

Thanks,
Tomas
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 09 May 2018, 10:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#58447   FS#58468   FS#58491   FS#58506 

Loading...