Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58491 - [freetype2] With 2.9.1-1, residualvm and scummvm can't find dependency

Attached to Project: Arch Linux
Opened by Faalagorn (Faalagorn) - Tuesday, 08 May 2018, 08:53 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 08 May 2018, 13:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since FreeType 2.9.1-1, when building residualvm or scummvm projects (not necessarily the newest version), running `/.configure` fails to find dependency, with

`WARNING: Disabling engine Z-Vision because the following dependencies are unmet: FreeType2` (for ScummVM), or
`WARNING: Disabling engine The Longest Journey because the following dependencies are unmet: FreeType2` (for ResidualVM)

Resulting in the following engines not building and being unusable.

When downgrading to lower version from pacman cache (`pacman -U /var/cache/pacman/pkg/freetype2-2.9-2-x86_64.pkg.tar.xz`), the errors disappear and engines work.

Afterwards, package can be upgraded and things still seem to work, so my assumption it's just the check that's wrong.

The actual checks performed in projects are repsectively at lines [4669](https://github.com/scummvm/scummvm/blob/master/configure#L4669) for ScummVM and [4607](https://github.com/residualvm/residualvm/blob/master/configure#L4607) for ResidualVM at the time of writing.

Additional info:
* package version(s)
** FreeType2 2.9.1-1 (causing the bug) 2.9-2 (not causing the bug)
** [scummvm-git r70525.75d1385-1](https://aur.archlinux.org/packages/scummvm-git/)
** [residualvm-git r7048.de230485-1](https://aur.archlinux.org/packages/residualvm-git/)


Steps to reproduce:
* make sure the system is up to date (`pacman -Syu`) and freetype2 is at 2.9.1-1 (`pacman -Q freetype2`),
* try to build either scummvm-git or residualvm-git (`makepkg`) or navigate to the src folder and `/.configure`,
* note the `WARNING: Disabling engine Z-Vision because the following dependencies are unmet: FreeType2` (for ScummVM), or `WARNING: Disabling engine The Longest Journey because the following dependencies are unmet: FreeType2` (for ResidualVM) – if building with `makepkg` you can cancel ex. with ctrl+c to save time,
* downgrade to freetype2 2.9-2 (`pacman -U /var/cache/pacman/pkg/freetype2-2.9-2-x86_64.pkg.tar.xz`),
* build/configure scummvm-git or residualvm-git again,
* notice the lack of errors.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 08 May 2018, 13:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See FS#58447
Comment by Faalagorn (Faalagorn) - Tuesday, 08 May 2018, 08:56 GMT
For some reason I thought the markdown formatting works here, but I think (hope!) the bug should be readable without formatting either, thanks to markdown quite unobtrusive style :).

Also forgot to link my comment on residualvm-git AUR page where I originally discovered the issue: https://aur.archlinux.org/packages/residualvm-git/?comments=all
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 08 May 2018, 09:30 GMT
They use `freetype-config`, which is gone in freetype2 2.9. Arch developers suggest patching relevant configure scripts to use pkg-config instead of freetype-config (https://bugs.archlinux.org/task/58447)

Loading...