Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58464 - [wireshark-cli] Couldn't load plugin 'l16mono.so'

Attached to Project: Community Packages
Opened by Ivan Grosnij (Tchelovek) - Saturday, 05 May 2018, 08:51 GMT
Last edited by Levente Polyak (anthraxx) - Thursday, 27 September 2018, 08:57 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: When issuing tshark -v from the command line, the following message is returned:

tshark: Couldn't load plugin 'l16mono.so': /usr/lib/wireshark/plugins/2.6/wiretap/l16mono.so: undefined symbol: register_codec
TShark (Wireshark) 2.6.0
.
.
.

According to upstream Bug 14638 - l16mono.so is installed in the wrong place. the file should reside in /usr/lib/wireshark/plugins/2.6/codecs.

Creating the directory and moving the file manually there solves the issue.

Since upstream indicates the issue as "fixed", there might be something amiss in packaging.

Additional info:
Linux GIGABYTE 4.16.6-1-ARCH #1 SMP PREEMPT Mon Apr 30 12:30:03 UTC 2018 x86_64 GNU/Linux
community/wireshark-cli 2.6.0-1

Steps to reproduce: Enter tshark -v at the command line
This task depends upon

Closed by  Levente Polyak (anthraxx)
Thursday, 27 September 2018, 08:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.3-1
Comment by Levente Polyak (anthraxx) - Thursday, 10 May 2018, 16:25 GMT
can you ask in that ticket which commit exactly is the fix?
Comment by Ivan Grosnij (Tchelovek) - Saturday, 12 May 2018, 03:29 GMT
At https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14638 a link is pointing to https://code.wireshark.org/review/#/c/27326/ where you will find the desired information.

Loading...