Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58461 - [firefox-developer-edition] Spell checking doesn’t work

Attached to Project: Community Packages
Opened by ariasuni (Sinma) - Friday, 04 May 2018, 21:22 GMT
Last edited by Andrew Crerar (andrewSC) - Friday, 11 May 2018, 15:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andrew Crerar (andrewSC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Since I upgraded to Firefox Developer Edition 61.0b1 (from 59.0b14-1), spell checking underlines in red all words — not punctuation or numbers —, no matter what dictionary I chose (be it system dictionary or a Firefox-specific one).

It works with Firefox Developer Edition downloaded from Mozilla.org (note that this one doesn’t use system dictionaries, but embedded and downloaded dictionaries work fine which is not the case with the packaged version).

Additional info:
* firefox-developer-edition 61.0b1 and 61.0b2
This task depends upon

Closed by  Andrew Crerar (andrewSC)
Friday, 11 May 2018, 15:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  pkgrel 2 removes soon to be invalid config option for enabling system dictionaries. Implements new method going forward.
Comment by Patrick (dampkwab) - Monday, 07 May 2018, 04:15 GMT
I'm getting the same problem on my end - here's what I've tried in case that helps anyone:
* Installed the official English (Australian) language dictionary add-on from https://addons.mozilla.org/en-US/firefox/language-tools/
* Installed community/firefox-developer-edition-i18n-en-gb and switched spell checker language to English (United Kingdom)
Unfortunately, neither of which seem to have had any effect and all words are still red-squiggly-underlined.
Comment by Piotr K (sargath) - Monday, 07 May 2018, 08:24 GMT
Same problem for me
Comment by Andrew Crerar (andrewSC) - Monday, 07 May 2018, 13:31 GMT
I can confirm this is an issue. I took a look into it last night and it's something to do with being able to read the dic and aff files. I'm going to continue to look into it.
Comment by Evan (lalalalalalala) - Thursday, 10 May 2018, 12:16 GMT
Has anybody come up with a workaround in the meantime? It makes typing in Firefox very difficult.

Here are some more people suffering from the same issue downstream in Manjaro:

https://forum.manjaro.org/t/firefox-developer-edition-61-spell-check-not-working/46838/7
Comment by Frederick Zhang (FrederickZh) - Thursday, 10 May 2018, 12:51 GMT
Can this be an upstream issue? I lost spell check in macOS recently as well (although I guess Firefox should be using the system's spell checker in mac?).
Comment by Andrew Crerar (andrewSC) - Thursday, 10 May 2018, 12:52 GMT
Thanks for the heads up. I've been doing diffs and trying to look through the source and I haven't found exactly where the problem is/was introduced or if this is a feature and the arch package needs to install dictionaries to some other path etc... I think the issue is related to the open syscall prepending "file://" to the path of the system dictionary which in turn causes open to return a ENOENT error. You can see this for yourself by running `strace -fv /usr/lib/firefox-developer-edition/firefox > debug.out 2>&1` then going to some multiline text field and typing whatever, killing the command, then grepping the debug.out file for the en_US.add and en_US.dic files.
Comment by Andrew Crerar (andrewSC) - Thursday, 10 May 2018, 13:54 GMT
I've opened a ticket upstream for this: https://bugzilla.mozilla.org/show_bug.cgi?id=1460600

Loading...