Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58460 - js52 has conflicting files during system upgrade

Attached to Project: Arch Linux
Opened by Noah (Euphoria42) - Friday, 04 May 2018, 18:10 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 04 May 2018, 18:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Performing 'pacman -Syu' to begin an upgrade fails when checking for file conflicts due to package js52 version 52.7.3-1. The conflicting file is '/usr/lib/libmozjs-52.so.0' and 'pacman -Qo /usr/lib/libmozjs-52.so.0' shows that the file is still owned by the package js52.

Additional info:
* Affected package(s): js52 - version 52.7.3-1
* ~ - sudo pacman -Syu
[sudo] password for redacted:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (3) ceph-libs-12.2.5-1 js52-52.7.3-2 python2-2.7.15-1

Total Download Size: 30.16 MiB
Total Installed Size: 153.85 MiB
Net Upgrade Size: 0.46 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
python2-2.7.15-1-x86_64 12.1 MiB 13.4M/s 00:01 [######################] 100%
js52-52.7.3-2-x86_64 10.9 MiB 14.3M/s 00:01 [######################] 100%
ceph-libs-12.2.5-1-... 7.1 MiB 14.6M/s 00:00 [######################] 100%
(3/3) checking keys in keyring [######################] 100%
(3/3) checking package integrity [######################] 100%
(3/3) loading package files [######################] 100%
(3/3) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
js52: /usr/lib/libmozjs-52.so.0 exists in filesystem
Errors occurred, no packages were upgraded.
~ - pacman -Qo /usr/lib/libmozjs-52.so
/usr/lib/libmozjs-52.so is owned by js52 52.7.3-1
~ - pacman -Q js52
js52 52.7.3-1

Steps to reproduce:
* Have package js52-52.7.3-1 installed
* Attempt to upgrade said package to version 52.7.3-2
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 04 May 2018, 18:24 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#58459 

Loading...