Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58448 - libreoffice-fresh /usr/bin/oosplash: No such file or directory

Attached to Project: Arch Linux
Opened by Simon Morris (bubba_169) - Friday, 04 May 2018, 06:58 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 08 May 2018, 13:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With the latest updates I get /usr/bin/oosplash: No such file or directory when trying to launch libreoffice 6.0.3-2 from the command line. Libreoffice was installed using the libreoffice-fresh package from the repos and is running on KDE. The desktop icons do nothing. Using lowriter to launch writer works fine.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 08 May 2018, 13:34 GMT
Reason for closing:  Works for me
Additional comments about closing:  OP request: "No longer happening after system reinstall"
Comment by Eli Schwartz (eschwartz) - Monday, 07 May 2018, 20:20 GMT
There is no /usr/bin/oosplash but this is because it is /usr/lib/libreoffice/program/oosplash

All the entry points in /usr/bin for libreoffice do are re-execute /usr/lib/libreoffice/program/soffice
So lowriter would be the same as libreoffice --writer, which, both of them run the "soffice" shellscript wrapper which itself just fancily invokes oosplash. So I don't know why this would fix anything.

But... Libreoffice opens just fine for me. I don't know why it would be looking in /usr/bin for you. *Unless* you're not using the packaged files. If the libreoffice wrapper you're using is running "soffice" from /usr/bin instead of /usr/lib/libreoffice/ then it would try to find oosplash in /usr/bin too. Which is obviously an issue.

Comment by Simon Morris (bubba_169) - Tuesday, 08 May 2018, 12:06 GMT
I'm it might have been somehow related to a freeze part way through a pacman system update that happened a few days before. I tried reinstalling libreoffice from both fresh and still but neither worked and had the same error. I've since reinstalled arch (this time with gnome instead though) and after that it works fine.

Thanks for your comment though eschwartz. I feel like I've learned something :)

Loading...