Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58431 - Spectacle won't launch

Attached to Project: Arch Linux
Opened by Alexis Phoenix (throbscottle) - Wednesday, 02 May 2018, 21:54 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 03 May 2018, 12:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Won't launch. When launching from a console I get:

spectacle: symbol lookup error: spectacle: undefined symbol: _ZN12KDeclarative12KDeclarative12setupContextEv

Similar bugs on the KDE bug tracker suggest it is a compilation issue

Has never worked since installation

Additional info:
* package version(s) 18.04.0-1
* config and/or log files etc. none

depends=(xcb-util-cursor libkipi purpose knewstuff)
makedepends=(extra-cmake-modules kdoctools)

Steps to reproduce: attempt to launch spectacle from a console
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 03 May 2018, 12:47 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial upgrades are unsupported
Comment by Antonio Rojas (arojas) - Wednesday, 02 May 2018, 22:12 GMT
which version of kdeclarative?
Comment by Alexis Phoenix (throbscottle) - Thursday, 03 May 2018, 12:46 GMT
kdeclarative 5.44.0-1

I just upgraded to 5.45.0-1 - spectacle works now. Perhaps it needs to pull the correct version in as a dependency?

Many thanks :)

Loading...