Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58423 - [kwin] Closing a window or using dialog disconnects my account.

Attached to Project: Arch Linux
Opened by Pedro Gabriel Drumond Pereira (pedrogabriel) - Wednesday, 02 May 2018, 03:03 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 10 May 2018, 22:23 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I try to use wayland session of plasma any system interactions (e.g. closing windows, responding to dialog...) make my system hang for a few minutes, then logoff back to sddm. The same not occurs in plasma xorg session. The problem dates at last from plasma-wayland-session 5.12.4.

Additional info:
* package version(s)
plasma-wayland-session 5.12.5-1
plasma-workspace 5.12.5-1
kwayland-integration 5.12.5-1
xorg-server-xwayland 1.19.6+13+gd0d1a694f-2
qt5-wayland 5.10.1-3

* config and/or log files etc.
No extra configuration was done.

Steps to reproduce:
* Start plasma wayland
* Open an window
* Try to close that window
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 10 May 2018, 22:23 GMT
Reason for closing:  Upstream
Comment by Antonio Rojas (arojas) - Friday, 04 May 2018, 06:11 GMT
logs? backtrace?
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Friday, 04 May 2018, 12:10 GMT
I will try to get some, but it's hard when my system just logoff.
Comment by Antonio Rojas (arojas) - Friday, 04 May 2018, 12:14 GMT
journal and coredumps are still available after logoff
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Friday, 04 May 2018, 16:57 GMT
The relevant time is about 13:50
Comment by Antonio Rojas (arojas) - Friday, 04 May 2018, 17:58 GMT
So kwin is crashing, as expected, but the coredump is larger than 2G so it's not being saved. Try increasing ExternalSizeMax in /etc/systemd/coredump.conf, without a backtrace there's not much we (or KDE for that matter) can to about this
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Friday, 04 May 2018, 19:31 GMT
New journalctl and coredumpctl's backtrace. The coredump itself is about 20mb and I can't send it here.
Comment by Antonio Rojas (arojas) - Friday, 04 May 2018, 19:46 GMT
Alright, thanks. The crash is caused by the aurorae window decoration engine. Please report it upstream and, in the meantime, switch to one of the official window decorations (breeze or oxygen)

Loading...