Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58403 - [libsynctex] API/ABI change

Attached to Project: Arch Linux
Opened by Håvard Pettersson (haavard) - Monday, 30 April 2018, 10:22 GMT
Last edited by Jelle van der Waa (jelly) - Monday, 30 April 2018, 14:43 GMT
Task Type Bug Report
Category Packages: Testing
Status Assigned
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No

Details

Latest libsynctex changed its public API/ABI, which completely breaks the zathura pdf viewer. Opening any pdf document results in an error: "zathura: symbol lookup error: zathura: undefined symbol: synctex_next_result".

Additional info:
* libsynctex 2018.47465-1
* zathura 0.3.9-1 / zathura-pdf-poppler 0.2.9-1
* Debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895980
* GitHub bug: https://github.com/jlaurens/synctex/issues/23

Steps to reproduce:
$ zathura document.pdf
This task depends upon

Comment by Håvard Pettersson (haavard) - Monday, 30 April 2018, 11:02 GMT
Zathura is patched upstream: https://git.pwmt.org/pwmt/zathura/commit/c97d83f6cee24dc2afc607eef6210b1274048c8a

Not sure about qpdfview, which is also affected.
Comment by Joss Wright (tealeaf) - Tuesday, 01 May 2018, 12:17 GMT
I'm seeing a failure when building zathura-git:

In file included from ../zathura/zathura/synctex.c:8:0:
/usr/include/synctex/synctex_parser.h:53:10: fatal error: synctex_version.h: No such file or directory
#include "synctex_version.h"
^~~~~~~~~~~~~~~~~~~
Comment by David McInnis (daavve) - Thursday, 03 May 2018, 10:05 GMT
qpdfview is also affected:

$ qpdfview
qpdfview: symbol lookup error: qpdfview: undefined symbol: synctex_next_result
Comment by Eli Schwartz (eschwartz) - Thursday, 03 May 2018, 11:04 GMT
Indeed.

> Comment by Håvard Pettersson (haavard) - Monday, 30 April 2018, 07:02 GMT-4
> > Zathura is patched upstream: https://git.pwmt.org/pwmt/zathura/commit/c97d83f6cee24dc2afc607eef6210b1274048c8a
> > Not sure about qpdfview, which is also affected.
Comment by Johannes Löthberg (Kyrias) - Thursday, 03 May 2018, 19:08 GMT
For zathura I've disabled synctex support for now, until libsynctex is unborked.
Comment by Genevieve Mendoza (aenda) - Thursday, 03 May 2018, 20:06 GMT
Zathura-git should have fixed all problems, the issue is with Arch's installation of texlive missing /usr/include/synctex/synctex_version.h. Debian fixed it with this simple patch:
https://salsa.debian.org/tex-team/texlive-bin/blob/master/debian/patches/fix-synctex-missing-header-install.
Issue on zathura's tracker: https://git.pwmt.org/pwmt/zathura/issues/16.
Comment by Håvard Pettersson (haavard) - Monday, 07 May 2018, 17:34 GMT
Johannes: why did you "fix" zathura in [community] when it's only broken in [testing]? I had to help a friend debug his broken zathura/latex workflow today because of this, and we ended up downgrading to 0.3.9-1.
Comment by Sebastian Stammler (epinephrine) - Tuesday, 08 May 2018, 10:06 GMT
I agree. I downgraded to 0.3.9-1 and it is working again. I need the -x/--synctex-editor-command flags for my inverse search to function. Please sort this out.
Comment by Sebastian Stammler (epinephrine) - Wednesday, 09 May 2018, 07:20 GMT
@aenda are the texlive maintainers aware of this patch to add synctex_version.h?
Comment by Sebastian Stammler (epinephrine) - Thursday, 17 May 2018, 21:43 GMT
Now I get
zathura: symbol lookup error: zathura: undefined symbol: synctex_next_result
from current version 0.3.9-3
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 26 May 2018, 22:47 GMT
texlive-bin 2018.47465-2 now has the missing header (synctex_version.h).
zathura 0.4 is available upstream with the fix
Comment by Johannes Löthberg (Kyrias) - Sunday, 27 May 2018, 00:17 GMT
zathura 0.4.0-4 in [community-testing] has been built with libsynctex re-enabled now.

The zathura 0.4 release still doesn't work properly upstream though, it checks for synctex version 2.0.0, but the version reported is actually 1.21.0, hm.

Loading...