Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58390 - [jenkins] Requires Java 8, not >=8

Attached to Project: Community Packages
Opened by Tharre (Tharre) - Sunday, 29 April 2018, 12:49 GMT
Last edited by Felix Yan (felixonmars) - Monday, 30 December 2019, 20:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Jenkins currently depends on java-runtime>=8, but will only run on Java 8.

It should instead depend on java-runtime=8, and set the correct JAVA binary in /etc/conf.d/jenkins.

Additional info:
systemd[1]: Started Extendable continuous integration server.
jenkins[25972]: Jenkins requires Java 8, but you are running 10.0.1+10 from /usr/lib/jvm/java-10-openjdk
jenkins[25972]: java.lang.UnsupportedClassVersionError: 54.0
jenkins[25972]: at Main.main(Main.java:128)

Steps to reproduce:

archlinux-java set java-10-openjdk
systemctl start jenkins
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 30 December 2019, 20:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.210-2
Comment by Radek Podgorny (rpodgorny) - Wednesday, 09 May 2018, 16:35 GMT
any progress on this? i'm also hit by this one. i guess hard-coding a path to java8 in conf.d would be fine.
Comment by Pri Vacy (essenceoffoo) - Sunday, 21 October 2018, 11:05 GMT
I just did a fresh install of Jenkins.

$ java -version
openjdk version "10.0.2" 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13)
OpenJDK 64-Bit Server VM (build 10.0.2+13, mixed mode)

And jenkins wouldn't start. I checked

$ sudo journalctl -u jenkins.service
[...]
Running with Java class version 54.0, but 52.0 is required.Run with the --enable-future-java flag to enable such behavior. See https://jenkins.io/redirect/java-support/

So I edited /etc/conf.d/jenkins and added/changed the option

JENKINS_OPTS=--enable-future-java

Now Jenkins is running and I can use the web interface.

Please keep in mind that I am completely new to Jenkins. I might have missed negative side effects of this solution.

edit: Not directly related to this bug, but I could not install the cloudbees-folder plugin. I had to restart the Jenkins server after entering the password and then it worked (related: https://stackoverflow.com/questions/37358775/jenkins-2-5-installation-error-an-error-occurred-during-installation-forbidden#38931127)

edit2: And I also got a blank page after logging in. Restarting the server via http://localhost:8090/restart solved this problem.
Comment by loqs (loqs) - Sunday, 21 October 2018, 12:57 GMT Comment by Colton Lewis (cowile) - Wednesday, 27 November 2019, 08:36 GMT
Bump this issue because the package still ships broken by using /usr/bin/java in /etc/conf.d/jenkins. It should use the binary for the JRE version it depends on instead of /usr/bin/java, which could symlink to any version. I've attached a one line diff against the file shipped with jenkins=2.205-1

Loading...