Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58389 - [libreoffice-fresh] Any keyboard input via japanese input crashes Libreoffice

Attached to Project: Arch Linux
Opened by Julien (julroy67) - Sunday, 29 April 2018, 12:33 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 03 June 2018, 12:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
When I press any key in Libreoffice through the japanese input (ibus-kkc, but it's also true for ibus-mozc) Libreoffice immediatly crashes. There is no information printed in the terminal when executed from there, so I've no idea what may cause it.

Additional info:
* libreoffice-fresh 6.0.3-2
* ibus 1.5.18-1
* ibus-kkc 1.5.22-1
* ibus-mozc 2.23.2815.102-1

Steps to reproduce:
1. Launch Libreoffice
2. Switch to japanese (ibus-kkc)
3. Press any key and watch libreoffice crash
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 03 June 2018, 12:02 GMT
Reason for closing:  Fixed
Comment by 甘露(Lu Gan) (ganlu) - Tuesday, 15 May 2018, 08:15 GMT
I got the same issue with ibus-libpinyin, however ibus-rime works well. And ibus-libpinyin developer suggested me to report here.
Comment by Xiang Fan (sfanxiang) - Sunday, 27 May 2018, 08:40 GMT
This might be a related stack trace. I obtained it by typing with libpinyin in a libreoffice dialog.
Comment by Erkki Hurme (quasd) - Wednesday, 30 May 2018, 14:40 GMT
Had this same issue, switching back to Xorg fixed it for me. (Gnome/Gdm) -> (Gnome/Xorg)
Comment by Julien (julroy67) - Sunday, 03 June 2018, 06:30 GMT
Seems to be fixed.
With all packages updated, I'm now able to input japanese in LibreOffice via ibus.

Loading...