Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58296 - [linux] Can't adjust backlight brightness anymore since kernel 4.16

Attached to Project: Arch Linux
Opened by Jürgen Feste (jf25) - Saturday, 21 April 2018, 09:11 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 03 May 2018, 08:07 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
The update of the linux kernel from 4.15.15-1 to 4.16.3-1 broke my backlight control. I can no longer adjust its brightness by either the Fn keys nor by software. The directory /sys/class/backlight/ is just empty. It used to contain acpi_video0 and acpi_video1 (I don't know why there where two subdirectories for 1 screen). My laptop is a MSI CX70 from 2012. I have two GPUs which I both run with open drivers (intel and nouveau):
[code]% lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)[/code]
Switching the whole screen off via [code]xset dpms force off[/code] still works.

Additional info:
* package version(s)
linux 4.16.3-1
* config and/or log files etc.


Steps to reproduce:
- boot the system
- ls /sys/class/backlight/ shows empty directory
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 03 May 2018, 08:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.16.6
Comment by Jürgen Feste (jf25) - Saturday, 21 April 2018, 09:16 GMT
attaching dmesg log files for both linux kernels.
Comment by loqs (loqs) - Saturday, 21 April 2018, 11:11 GMT
If you remove the acpi_backlight=video option under 4.16 is there any difference?
Comment by Jürgen Feste (jf25) - Saturday, 21 April 2018, 12:08 GMT
Nope. Are there any more log files/info which could be helpful?
Comment by Tomek Zdybał (tomekzet) - Sunday, 22 April 2018, 20:51 GMT
I have the similar issue with Nvidia Quadro M2200 (Dell Precision 7520) - brightness control stopped working after recent updates.

I'm using nvidia driver. Problem is present on both linux and linux-lts packages.
I tried acpi_backlight values (with linux/nvidia, non-lts): none, vendor, video, native - without success.
Comment by Bill (QuimaxW) - Monday, 23 April 2018, 10:40 GMT
nvidia-340xx-dkms-340.106-29

linux-zen-4.16.3-1 - Backlight quit working

Downgrade to
linux-zen-4.15.15-1 - Backlight works fine

However...
linux-zen-4.16.3-1 & xf86-video-nouveau works fine as well.

Willing to troubleshoot, but I do need some guidance on where to start.
Comment by loqs (loqs) - Friday, 27 April 2018, 22:11 GMT Comment by Bill (QuimaxW) - Saturday, 28 April 2018, 02:32 GMT
linux-zen 4.16.4-1
nvidia-340xx-dkms 340.106-30

Adding video.only_lcd=0 puts that back light to it's normal functioning.
Comment by Jürgen Feste (jf25) - Saturday, 28 April 2018, 06:57 GMT
I can confirm. video.only_lcd=0 enables me to adjust the backlight again on linux 4.16.4-1. Excellent!
Comment by Tomek Zdybał (tomekzet) - Monday, 30 April 2018, 21:00 GMT
Same here! With this option, backlight control works. Thanks for help!
Comment by loqs (loqs) - Monday, 30 April 2018, 22:38 GMT Comment by Jürgen Feste (jf25) - Thursday, 03 May 2018, 08:01 GMT
I just installed linux 4.16.6-1 and now it works without manually setting the kernel parameter mentioned above. Thank you! The issue can be considered as solved.

Loading...