Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58291 - [namcap] Nonsensical "Referenced library 'python' is an uninstalled dependency" message

Attached to Project: Arch Linux
Opened by Antony Lee (anntzer) - Friday, 20 April 2018, 21:30 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 22 April 2018, 13:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Running namcap on the packaged python-sqlalchemy 1.2.6-1 (https://www.archlinux.org/packages/community/x86_64/python-sqlalchemy/) package, which does declare python as a dependency, yields the following nonsensical warning:
python-sqlalchemy W: Referenced library 'python' is an uninstalled dependency

(Even if this was a packaging error on python-sqlalchemy's side, which I doubt, the error message would still be overly cryptic.)

Additional info:
* package version(s): namcap 3.2.7, python-sqlalchemy 1.2.6-1.
* config and/or log files etc. N/A


Steps to reproduce:
Download python-sqlalchemy-1.2.6-1-x86_64.pkg.tar.xz from https://www.archlinux.org/packages/community/x86_64/python-sqlalchemy/ and run namcap on it.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 22 April 2018, 13:24 GMT
Reason for closing:  Works for me
Additional comments about closing:  OP cannot reproduce
Comment by Doug Newgard (Scimmia) - Saturday, 21 April 2018, 05:55 GMT
I don't get that warning. Do you actually have the "python" package installed?
Comment by Antony Lee (anntzer) - Saturday, 21 April 2018, 06:34 GMT
Yes.
(And even if I didn't, I would argue that that's not something namcap should warn about: that doesn't make the *package* invalid. But that's a side point.)
Comment by loqs (loqs) - Saturday, 21 April 2018, 12:21 GMT
Do you have a python.so on the system that produces the error?
https://git.archlinux.org/namcap.git/tree/Namcap/rules/sodepends.py?h=3.2.7#n167
Comment by Antony Lee (anntzer) - Saturday, 21 April 2018, 19:58 GMT
`locate python.so` doesn't yield anything of interest.
But I can't reproduce the error anymore, so this can be closed for now.

Loading...