Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58287 - evolution doesn't work after upgrade to 3.28.*

Attached to Project: Arch Linux
Opened by Mikhail Shiryaev (Felixoid) - Friday, 20 April 2018, 08:02 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 20 April 2018, 09:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: after last full system upgrade with evolution upgraded from 3.26.x to 3.28.x package stopped to launch with next error:
>ѳ> evolution
evolution: symbol lookup error: /usr/lib/libwebkit2gtk-4.0.so.37: undefined symbol: soup_session_connect_async
>ѳ> pacman -Qo /usr/lib/libwebkit2gtk-4.0.so.37
/usr/lib/libwebkit2gtk-4.0.so.37 is owned by webkit2gtk 2.20.1-1


Additional info:
* package version(s):
>ѳ> pacman -Q | grep -P 'evolution|webkit2'
evolution 3.28.1-1
evolution-data-server 3.28.1-1
evolution-ews 3.28.1-1
webkit2gtk 2.20.1-1


Steps to reproduce:
I'm not sure is it my special case or general.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 20 April 2018, 09:11 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 20 April 2018, 08:34 GMT
With what version of libsoup?
Comment by Mikhail Shiryaev (Felixoid) - Friday, 20 April 2018, 08:59 GMT
>±> pacman -Q| grep libsoup
libsoup-gnome 2.59.90.1-1

and in repo right now
>±> pacman -Ss libsoup
extra/libsoup 2.62.1-1
HTTP client/server library for GNOME

IDK why package wasn't replaced while upgrade, but after the manual install of libsoup evolution works.

Thank you for the hint

Loading...