Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58275 - [Linux] 4.16.2-2 freezes shortly after boot on hybrid laptop

Attached to Project: Arch Linux
Opened by Gunnar Bretthauer (Taijian) - Thursday, 19 April 2018, 15:28 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 20 April 2018, 09:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I run Arch on an Alienware 15R3 laptop with both an Intel iGPU and an AMD RX470 dGPU. After updating the core/linux package to 4.16.2-2 today, I can no longer boot into my system - or, more correctly, I can boot, but the system will freeze after entering my login credentials - both via GDM or CLI. I have tried to set amdgpu.dc=0, but that did not make a difference. What does allow me to boot is specifying modprobe.blacklist=amdgpu on the kcl.
Anyone have any idea what to do?

Additional info:
I have tried to recover a journal fragment of an unsuccessfull boot attempt and attached it, but I cannot really see anything in it that would point me to what's wrong.


Steps to reproduce:
Boot the system. Enter login credentials. Watch the system freeze.
   error (97.7 KiB)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 20 April 2018, 09:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User requested: OK, turns out it must have been something else, because after fiddling about a bit, it now works. No idea what caused it, though. Sorry for the inconvenience!

Loading...