Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58272 - [virtualbox-guest-utils] can't mount shared folder from fstab

Attached to Project: Community Packages
Opened by nl6720 (nl6720) - Thursday, 19 April 2018, 12:48 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 13 June 2018, 06:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
I just updated a VM that has vboxsf in /etc/fstab and I get this error on boot:
vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.

While I could do as the message says and remove /usr/bin/mount.vboxsf, the file will just get re-added on update.

Additional info:
* package version(s)
* config and/or log files etc.
virtualbox-guest-utils-nox 5.2.10-1
virtualbox-guest-modules-arch 5.2.10-2

Steps to reproduce:
add shared folder mount to /etc/fstab, reboot
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 13 June 2018, 06:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  Assuming fixed; reopen if further issues come up.
Comment by Evangelos Foutras (foutrelis) - Friday, 20 April 2018, 13:38 GMT
In 5.2.8-2 I patched mount.vboxsf to suggest using `mount -cit` but this obviously doesn't help with /etc/fstab entries. Note that we can't remove mount.vboxsf because it is needed to support older kernels.

Until upstream fixes the mount helper to work with the mainline vboxsf module, you can either declare "usr/bin/mount.vboxsf" as NoExtract in /etc/pacman.conf, or use vboxservice.service with automounting enabled for your shared directories.
Comment by Kishore (Doctor_Zoidberg) - Saturday, 26 May 2018, 05:45 GMT
Someone reported this bug here ( https://www.virtualbox.org/ticket/17728 ), and I am just pasting the reply by one of the developers, for the sake of completeness.

>I will comment here to save creating an account on the Arch bugtracker. If you use our Additions then you will get our kernel modules and our user-space binaries, which work together. However if you try to use our user-space binaries with the in-kernel modules you will get this. Removing mount.vboxsf should fix this particular issue. Hans made quite a few adjustments and fixes when he upstreamed in particular the shared folder module to the kernel which we currently do not have the developer capacity to re-integrate. By the way, volunteers are welcome (ping us on vbox-dev).
Comment by mxovd (mxovd) - Wednesday, 06 June 2018, 14:44 GMT
  • Field changed: Percent Complete (100% → 0%)
Just installed 5.2.12-2 and the error persists.

Thanks
Comment by Evangelos Foutras (foutrelis) - Wednesday, 06 June 2018, 19:50 GMT
@mxovd: What's the /etc/fstab line you're using and the share name configured in vbox?
Comment by mxovd (mxovd) - Monday, 11 June 2018, 20:08 GMT
  • Field changed: Percent Complete (100% → 0%)
Really sorry for the delay (and the reopen).

shared name = mxovd (C:\users\mxovd

mxovd /home/mxovd/Documents vboxsf uid=1000,gid=1000,dmode=700,fmode=600,x-systemd.automount 0 0

note: if I comment out the line in favor of vboxservice automount, it works but the error message is still displayed
Comment by mxovd (mxovd) - Tuesday, 12 June 2018, 07:06 GMT
Update:
I re-set all my folder/mounts, it seemed to fix some issues:
-mounting the shared folder with fstab vboxsf does works now without any error message.
-automounting the folder with vboxservice works but the error message is displayed.
I will mount using fstab. Thank you very much.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 12 June 2018, 07:34 GMT
The error message coming from vboxservice's automounting can be ignored. The same error ("Old binary mount data not supported ...") coming from an fstab mount means that either:

- Your /usr/bin/mount.vboxsf was not the script added in 5.2.12-2 [1], or
- For some reason the check in the above script failed to detect the 4.16+ kernel and, instead of /usr/bin/mount, it called /usr/lib/virtualbox/mount.vboxsf

[1] https://git.archlinux.org/svntogit/community.git/tree/trunk/mount.vboxsf?h=packages/virtualbox
Comment by mxovd (mxovd) - Wednesday, 13 June 2018, 06:14 GMT
Understood, everything is working as expected. Thanks for the help

Loading...