Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58269 - [chromium] crashes with: "Segmentation fault (core dumped)" on startup

Attached to Project: Arch Linux
Opened by Piotr Pejas (pejas) - Thursday, 19 April 2018, 10:20 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 19 April 2018, 18:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Chromium crashes with: "Segmentation fault (core dumped)" on startup
Tried with --data-path (clean home) and --disable-extensions

Happens on 3 different machines.

Additional info:
* package version(s) 66.0.3359.117-1
* config and/or log files etc.
kernel: chromium[13280]: segfault at 0 ip 000055fb420b3ae1 sp 00007ffda031d3d0 error 4 in chromium[55fb3e18d000+5f5b000]

Steps to reproduce:
1. Upgrade to latest chromium (66.0.3359.117-1).
2. Run
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 19 April 2018, 18:47 GMT
Reason for closing:  Upstream
Additional comments about closing:  Remove invalid --user-data-dir flag from $HOME/.config/chromium-flags.conf if you're on Antergos. The segfault itself has been reported against Chrome 66 at: https://crbug.com/834298
Comment by Rafał Rybak (roophie) - Thursday, 19 April 2018, 10:47 GMT
Same here: Kernel Version: 4.15.15-1-ARCH
Comment by James Pelster (jpmac26) - Thursday, 19 April 2018, 16:06 GMT
I am also encountering this crash, I've tried uninstalling chromium and reinstalling, as well as with/without flash-plugin/pepper-flash installed, and after about a full day it doesn't seem that updates for other packages have fixed the issue, so I'm unsure whether it's some strange dependency problem or an issue with chromium itself. I'm guessing it's the latter, but don't have enough knowledge to be sure.
Comment by Evangelos Foutras (foutrelis) - Thursday, 19 April 2018, 16:13 GMT
Is this on Arch or Antergos (or another derivative distro)? I am asking because of [1].

If it's on Arch, I'll have to upload a package with debugging symbols so we can get a meaningful backtrace.

[1] https://forum.antergos.com/topic/9677/chromium-is-broken/20
Comment by James Pelster (jpmac26) - Thursday, 19 April 2018, 16:35 GMT
My apologies, I am on Antergos, following the steps in the thread you mentioned fixed the issue for me.
Comment by Evangelos Foutras (foutrelis) - Thursday, 19 April 2018, 17:41 GMT
@James: I would suggest completely removing the --user-data-dir flag from chromium-flags.conf. (No need to change it to what Chromium already uses by default.)

While this is a configuration issue, Chrome's behavior has changed (it shouldn't segfault). More details here: https://crbug.com/834298#c4
Comment by Piotr Pejas (pejas) - Thursday, 19 April 2018, 18:36 GMT
I am also on Antergos and removing ~/.config/chromium-flags.conf fixes problem.
IMHO segfault for missing a dir is a little to much.
I went easy way thinking that Antergos is only a installer for Arch, and after installation and removing some packages I am on good old Arch my bad sorry for confusion.
As it is reported upstream I am requesting a closure.

Loading...