Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58264 - [ejabberd] Standard configuration not working || bad argument in call to fast_yaml

Attached to Project: Community Packages
Opened by phil koenig (phikoen) - Wednesday, 18 April 2018, 23:55 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 26 April 2018, 13:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I've installed the latest ejabberd version which is available in the community repo (18.03-1). I've configured it accordingly, created a mariadb user + database and imported the schema from https://github.com/processone/ejabberd/blob/master/sql/mysql.sql. I've configured mysql with skip-networking. However - Ejabberd is crashing. Please find below my config and the crashing log

Additional info:
* package version(s)
18.03-1 (community repo)
* config and/or log files etc.
I've tried to get in contact directly with ejabberd; However - the forum is read only. According to their forum you have to answer a question on serverfault, which I've already done there: https://serverfault.com/questions/907724/ejabberd-on-archlinux
ejabberd.yaml --> https://pastebin.com/mLw3fe2b
crash.log:
2018-04-19 01:51:00 =CRASH REPORT====
crasher:
initial call: application_master:init/4
pid: <0.64.0>
registered_name: []
exception exit: {{bad_return,{{ejabberd_app,start,[normal,[]]},{'EXIT',{badarg,[{fast_yaml,nif_decode,[<<"###\n###' ejabberd configuration file\n###\n###\n\n### The paramete$
ancestors: [<0.63.0>]
message_queue_len: 1
messages: [{'EXIT',<0.65.0>,normal}]
links: [<0.63.0>,<0.33.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 1598
stack_size: 27
reductions: 215
neighbours:

Steps to reproduce:
Install ejabberd
Configure ejabberd (with letsencrypt certificate + strong ciphers + mysql/mariadb backend)
Start ejabberd
Take a look onto /var/log/crash.log

Any help would be appreciated.

Best regards
phikoen
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 26 April 2018, 13:22 GMT
Reason for closing:  Not a bug
Comment by Sergej Pupykin (sergej) - Friday, 20 April 2018, 15:40 GMT
If you comment
s2s_ciphers:
c2s_ciphers:
it starts working
Comment by phil koenig (phikoen) - Saturday, 21 April 2018, 08:52 GMT
Dear Sergej Pupykin,

many thanks for your quick response - I've disable s2s_ciphers and c2s_ciphers and it's working like a charm!

Have a great day & a nice weekend!

best regards
phikoen

Loading...