Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58252 - [xmobar] requires GLIB 2.27, but arch currently uses 2.26

Attached to Project: Community Packages
Opened by Jon Irving (j0ni) - Tuesday, 17 April 2018, 16:18 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 17 April 2018, 20:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Attempting to run xmobar 0.26-4 just released today. It crashes with the following error:

```
xmobar: /usr/lib/libm.so.6: version `GLIBC_2.27' not found (required by xmobar)
```

Additional info:
* package version(s)
xmobar 0.26-4

* config and/or log files etc.



Steps to reproduce:

run `xmobar` on a "stock" Arch system, as of this moment :D 2018-04-17T17:17:00.000Z
This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 17 April 2018, 20:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.26-5
Comment by Eli Schwartz (eschwartz) - Tuesday, 17 April 2018, 16:24 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Low → High)
  • Task assigned to Felix Yan (felixonmars)
Comment by Cyril Cressent (ccressent) - Tuesday, 17 April 2018, 19:09 GMT
I ran into the same issue today after upgrading my system.
I worked around it by building my own `xmobar` package and installing it:

1. Get the latest PKGBUILD file for `xmobar`
2. Bump `pkgrel` (that might not be needed?)
3. Build a new `xmobar` package using `makepkg`
4. `pacman -U <new-package>`

You end up with an installed xmobar package that is built against whatever shared library version you have on your system.
Is it a legitimate way to "fix" this issue until a new version of the `xmobar` package is uploaded?
Comment by Jon Irving (j0ni) - Tuesday, 17 April 2018, 19:49 GMT
Sounds reasonable to me @ccressent - I just installed the `xmobar-git` package from AUR, which also gets built locally.

Loading...