Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58228 - [dnsmasq] time-out requests

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Saturday, 14 April 2018, 15:07 GMT
Last edited by Christian Hesse (eworm) - Thursday, 10 September 2020, 08:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have a box running Arch Linux that manages, among other things, my home network.
It is using "dnsmasq" for both managing DNS and DHCP.
It have been working fine for the last 4 years using the same setup, until recently.
After updating "dnsmasq" from version 2.78-2 to 2.79-1, the network clients started having trouble with DNS - eg. taking so long for the request to happen that the browsers end up giving up and reporting time-outs. These time outs would last for about 2-3 minutes approximately every 30 minutes and then everything would be back on track from another half hour or so.
Downgrading "dnsmasq" back to version 2.78-2 solves the time-out problems. Updating the package again will make the issues return.
I am not sure this is arch specific, or even some configuration corner case, but I don't see anything related in the upstream mailing list.
The changes in /etc/dnsmasq.conf between versions as far as my setup is concerned are only in commented lines, so it's not likely to be a "changed configuration issue".
During these "timeouts", nothing gets logged in journalctl regarding "dnsmasq".

Additional info:
* package version(s)
2.79-1
* config and/or log files etc.
N/A

Steps to reproduce:
Use an Arch Linux box to manage a small network using "dnsmasq". Update from version 2.78-2 to 2.79-1 and the issue will crop up.

PS - I'm not 100% sure this is an arch specific issue. Please let me know if this would be more appropriate to report upstream.
This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 10 September 2020, 08:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  dnsmasq 2.80-1
Comment by Francisco Pina (Stunts) - Saturday, 14 April 2018, 15:10 GMT
This was implicit, but not explicit in the original report:
The time-outs will occur on multiple devices in the network once "dnsmasq" is updated in the server (Arch Linux (up-to-date) laptops, Ubuntu 16.04 laptops, multiple versions of android phones and tablets).
My apologies for forgetting this information in the original report.
Comment by Francisco Pina (Stunts) - Thursday, 10 September 2020, 02:37 GMT
This was an upstream issue regarding DNSSEC and the "dnssec-check-unsigned" option. It has since been fixed in version 2.80. This can now be closed.

#BugDay2020

Upstream CHANGELOG where the fix is logged (second paragraph of version 2.80):
http://www.thekelleys.org.uk/dnsmasq/CHANGELOG
Comment by Christian Hesse (eworm) - Thursday, 10 September 2020, 08:41 GMT
Thanks!

Loading...