Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58218 - [mesa] 18.0.0-2 breaks bgfx

Attached to Project: Arch Linux
Opened by David Limbeck (puffi) - Friday, 13 April 2018, 17:11 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 14 April 2018, 18:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since mesa 18.0.0-2 (including 18.0.0-3) bgfx (https//github.com/bkaradzic/bgfx) segfaults with: ../mesa-18.0.0/src/gallium/auxiliary/util/u_blitter.c:2032: util_blitter_generate_mipmap: Assertion `!util_format_has_stencil(desc)' failed.
All examples work with mesa 18.0.0-1 and 17.3.7-1.

Additional info:
mesa 18.0.0-2
mesa 18.0.0-3


Vendor: X.Org
Renderer: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.16-1-ck-k10, LLVM 6.0.0)
Version: 3.0 Mesa 18.0.0
BGFX GLSL version: 1.30


Steps to reproduce:
Download and build bgfx (https://bkaradzic.github.io/bgfx/build.html) then run the examples.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 14 April 2018, 18:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 18.0.0-4
Comment by Evangelos Foutras (foutrelis) - Saturday, 14 April 2018, 06:54 GMT
Another report of the same issue: https://steamcommunity.com/app/677120/discussions/2/1694917906662691247/

Weird that the switch to meson would cause an assertion failure.
Comment by Jan Alexander Steffens (heftig) - Saturday, 14 April 2018, 16:14 GMT
Seems this crashes now because the meson build doesn't disable assertions (NDEBUG is not defined).
Comment by Jan Alexander Steffens (heftig) - Saturday, 14 April 2018, 16:26 GMT
Please test 18.0.0-4.
Comment by David Limbeck (puffi) - Saturday, 14 April 2018, 17:15 GMT
Works with 18.0.0-4.

Loading...