Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58210 - [flake8][python-pycodestyle] Flake8 does not support pycodestyle>=2.4.0

Attached to Project: Community Packages
Opened by Rupus Reinefjord (nameequalsmain) - Thursday, 12 April 2018, 11:49 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 20 April 2018, 14:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
Flake8 does not support pycodestyle>=2.4.0, dependency is "pycodestyle >= 2.3.0, < 2.4.0". Flake8 cannot run at all with pycodestyle 2.4.0 and errors out with the following exception:
```
flake8.exceptions.FailedToLoadPlugin: Flake8 failed to load plugin "pycodestyle.break_around_binary_operator" due to module 'pycodestyle' has no attribute 'break_around_binary_operator'.
```

Upstream issues:
flake8: https://gitlab.com/pycqa/flake8/issues/406
pycodestyle: https://github.com/PyCQA/pycodestyle/issues/741

Additional info:
flake8 1:3.5.0-1
python-pycodestyle 2.4.0-1


Steps to reproduce:
Run flake8 3.5.0 with pycodestyle 2.4.0.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 20 April 2018, 14:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  flake8 1:3.5.0-2
Comment by Diego Abad A (vperilla) - Thursday, 12 April 2018, 15:28 GMT
install flake8 and python-pycodestyle
python -m flake8 to reproduce bug
Comment by Abdó Roig-Maranges (abdo) - Saturday, 14 April 2018, 07:55 GMT
flake8 3.5 depends on pycodestyle <2.4.0: https://github.com/PyCQA/flake8/blob/3.5.0/setup.py and flake8. We probably should downgrade pycodestyle version until flake8 supports 2.4
Comment by Daniel Hahler (blueyed) - Saturday, 14 April 2018, 19:35 GMT
In https://github.com/PyCQA/pycodestyle/issues/741#issuecomment-380261935 it was mentioned that "pip check" complains about the mismatched dependency.

I think this could be made of use in some way to check if Arch's Python package deps are OK in this regard.

However I could not get the warning using the system's pip (https://github.com/PyCQA/pycodestyle/issues/741#issuecomment-381354443).
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 15 April 2018, 17:11 GMT
There are two patches proposed at upstream:

https://gitlab.com/pycqa/flake8/merge_requests/230 (marked as "do-not-merge", though)
https://gitlab.com/pycqa/flake8/merge_requests/231

UPDATE: both merge requested are merged
Comment by Stefan Schwarz (foosinn) - Tuesday, 17 April 2018, 07:22 GMT
In the meantime i downgraded to 2.3.1
   PKGBUILD (1.7 KiB)
Comment by Mantas (sirex) - Thursday, 19 April 2018, 18:44 GMT
This fixed flake8 for me:

sudo pacman -U /var/cache/pacman/pkg/python-pycodestyle-2.3.1-1-any.pkg.tar.xz
Comment by Eli Schwartz (eschwartz) - Friday, 20 April 2018, 14:37 GMT
Backported those two merged MRs.

Loading...