Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58209 - [dnscrypt-proxy] Keep inline with upstream 'DynamicUser' setup

Attached to Project: Community Packages
Opened by helle vaanzinn (glitsj16) - Thursday, 12 April 2018, 11:31 GMT
Last edited by David Runge (dvzrv) - Friday, 13 April 2018, 07:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The PKGBUILD and configuration.diff could use a tune-up.

One purely cosmetic edit to keep up with upstream's changed project description:
pkgdesc="A flexible DNS proxy, with support for modern encrypted DNS protocols."
(cfr. https://github.com/jedisct1/dnscrypt-proxy/commit/b23a0fa00740b8b7fd23f8af675687cc8696adf8).

The second one is more important, as it doesn't keep fully inline with upstream's usage of
systemd's 'DynamicUser' setup (LogsDirectory=dnscrypt-proxy):
configuration.diff:
+# log_file = '/var/log/dnscrypt-proxy.log'
should be
+# log_file = '/var/log/dnscrypt-proxy/dnscrypt-proxy.log'
(cfr. https://github.com/jedisct1/dnscrypt-proxy/blob/master/systemd/dnscrypt-proxy.service)

Regards.
This task depends upon

Closed by  David Runge (dvzrv)
Friday, 13 April 2018, 07:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2.0.9-2
Comment by Eli Schwartz (eschwartz) - Friday, 13 April 2018, 00:27 GMT
Please fill out the Description properly next time. The Add New Bug link on the package details page does this automatically.

Loading...