Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58205 - [linux] 4.16 Breaks Touchpad With Null Pointer Dereference

Attached to Project: Arch Linux
Opened by Chet Gurevitch (chetgurevitch) - Wednesday, 11 April 2018, 23:35 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 19 April 2018, 09:15 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Using T440P w/ Synaptics TM3053-004 as identified by libinput on 4.15 kernels. 100% reproducable.

Additional info:
* linux version 4.16.1-1
* log attached
   log (12.9 KiB)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 19 April 2018, 09:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.16.2-2
Comment by loqs (loqs) - Thursday, 12 April 2018, 07:53 GMT Comment by Chet Gurevitch (chetgurevitch) - Thursday, 12 April 2018, 22:17 GMT
Seems like the wrong patch was sent originally but this did the trick https://github.com/torvalds/linux/commit/a95845ba184b854106972f5d8f50354c2d272c06.patch
Comment by Doug Newgard (Scimmia) - Friday, 13 April 2018, 14:07 GMT
Was this fixed in 4.16.2-1?
Comment by loqs (loqs) - Friday, 13 April 2018, 20:01 GMT
No patches for v4l2-core since the 4.16 release.
Edit:
To clarify I mean commits to linux-stable not mainline.
Comment by loqs (loqs) - Saturday, 14 April 2018, 16:49 GMT

Loading...